public void testAverageTotalStartedThreadCount() {}
you could just skip the prefix "test" and go with the annotation only:
@Test
public void averageTotalStartedThreadCount() {}
The "test" prefixes are still generated by Eclipse and NetBeans, so if you don't like the superfluous naming, you will have to remove it manually. The "test" prefix in the test-class name, however, is still useful. It makes the search for test classes more easy.